A variety of issues

Dartagnan's Avatar

Dartagnan

07 Jan, 2014 12:31 AM

Hi all,

I like the software but seem to be having many issues! List below;

  1. Software freezes on 1 track and can select the others but seems to keep the same track on screen.
  2. Cant edit the tablature at all
  3. Cant see the blue dot
  4. Pressing space doesn't take me to the next bar, just freezes
  5. In general, doesn't seem to be functioning at all!

I have tried uninstalling and re installing.

Appreciate your help on this!

Dartagnan

  1. Support Staff 1 Posted by Jarod Long on 07 Jan, 2014 12:37 AM

    Jarod Long's Avatar

    Hey,

    Sorry for the trouble! It sounds like this might be a problem with a particular document you have open. While the app is opening, hold Command + Option + Control, which will cause the app to not re-open any documents that were open last time.

    Try opening another document and see if you have the same problem. If not, you can send me the document that's causing the problem and I'd be happy to fix it for you so you can open it again.

    Let me know if this helps!

  2. 2 Posted by Dartagnan Sween... on 07 Jan, 2014 02:14 AM

    Dartagnan Sweeney's Avatar

    Hi Jarod,

    I tried your suggestion to fix the issue in Tabular but had no luck.

    Attached is the document I am having problems with.

    Thanks for your help,

    Dart

    ---------- Forwarded message ----------
    From: Dartagnan Sweeney <[email blocked]>
    Date: 7 January 2014 13:10
    Subject: Fractured tab
    To: "[email blocked] Sweeney" <[email blocked]>

  3. Support Staff 3 Posted by Jarod Long on 07 Jan, 2014 03:48 AM

    Jarod Long's Avatar

    Alright, there was a problem with one of the tracks where some of the measures didn't have any divisions in them. I've attached the fixed document, which you should be able to import back into the app.

    There's some kind of bug in the app that caused the document to end up that way. If you happen to remember anything in particular you did in the app before this started happening, that'd be really helpful in figuring out what's causing the bug.

    Apologies again for the inconvenience!

  4. 4 Posted by Dartagnan Sween... on 07 Jan, 2014 03:57 AM

    Dartagnan Sweeney's Avatar

    Hi Jarod,

    Cant remember anything specific I did before the issue started but will let
    you know if it comes up again.

    It may be worth knowing I imported the file from a Guitar pro 5 generated
    midi file.

    By the way, I love the app despite the issue. I can't see tabular for iPad
    in the app store, is there anything out or planned?

    Dart

  5. Support Staff 5 Posted by Jarod Long on 07 Jan, 2014 04:04 AM

    Jarod Long's Avatar

    No problem, thanks for the info!

    Nice to hear you're enjoying the app :) The iPad version isn't out yet, unfortunately -- I was hoping for an end of 2013 release, but it's taking a bit longer than I expected. It's coming along nicely, though, and should be ready early this year.

  6. 6 Posted by Dartagnan Sween... on 07 Jan, 2014 11:04 AM

    Dartagnan Sweeney's Avatar

    Hi Jarod,

    Worked for a while, then it froze, now it won't seem to play back and I
    can't change the track.

    This is the same file you had sent me and had been working fine for about
    the last hour. Am I doing something to generate this issue?

    Dart

  7. Support Staff 7 Posted by Jarod Long on 07 Jan, 2014 06:40 PM

    Jarod Long's Avatar

    Yeah, this is the exact same issue as before. Three measures in a row end up without any divisions somehow. It's unfortunately difficult for me to pin down the cause of the issue without any more information, but I'll continue to look into it and see if I can figure it out.

    Likely culprits are copy and paste or undo/redo. Do you think you'd been doing either of those right before this started happening?

    The fixed version of the document is attached.

  8. 8 Posted by Dart Sweeney on 07 Jan, 2014 08:29 PM

    Dart Sweeney's Avatar

    Hi Jarod,

    This time i think it deleted the contents of 4 bars, they then remained pink and the problems started from there. I couldn't select or change anything and the pink remained. I restarted the app and then playback wouldn't work etc.

    Regards

    Dartagnan Sweeney

  9. Support Staff 9 Posted by Jarod Long on 07 Jan, 2014 09:54 PM

    Jarod Long's Avatar

    Hmm, I can't seem to recreate the problem. Do you remember exactly how you deleted the contents of the measures? It's supposed to leave a rest inside of a measure whenever you delete everything inside of it, but it sounds like it's not doing that for some reason.

    Sorry for all the questions, this is turning out to be a difficult problem to solve!

  10. 10 Posted by Dartagnan Sween... on 07 Jan, 2014 10:51 PM

    Dartagnan Sweeney's Avatar

    Hi Jarod,

    No problem on the questions, happy to help you fix the issue.

    I used command+delete to delete the content from the 4 bars.

    When I get a chance, Ill do some testing and try it again.

    Dart

  11. 11 Posted by Dartagnan Sween... on 10 Jan, 2014 12:10 AM

    Dartagnan Sweeney's Avatar

    Hi Jarod,

    There definitely a problem when using command - delete. Attached just
    happened, random notes and others appeared.

    Also, I can't seem the change the 'vince clean' track to clean guitar. It
    just stays as distorted.

  12. Support Staff 12 Posted by Jarod Long on 11 Jan, 2014 01:19 AM

    Jarod Long's Avatar

    Hmm, I've been trying to reproduce this and I just can't seem to do it. Something else must be happening before you use Command+Delete that causes this issue to occur.

    It would help to see if there's anything in being put into the console when this is going on. While you have the app running, open up Console.app (located in /Applications/Utilities) and keep it in the background until the issue happens again. When it does, inside Console click on Tabular at the bottom left to filter the messages to ones coming from the app. If you could send me whatever shows up there, I'd really appreciate it! If there's lots of text then the most recent couple hundred lines should be enough.

    As for the issue with changing the track's sound, in the document you sent me, the "vince clean" track is already set to clean guitar, and it seems to work when I change it to other sounds. Are you not able to change the sound of any track or just that one?

  13. 13 Posted by Dartagnan Sween... on 13 Jan, 2014 11:12 AM

    Dartagnan Sweeney's Avatar

    Ok, I think I may have found what I have been doing.

    I copied 1 bar of music, selecting 2 then trying to paste it in. I tried it
    in the attached around the 124th bar in the track named 'tristan'.

    Can you recreate it?

  14. Support Staff 14 Posted by Jarod Long on 13 Jan, 2014 07:15 PM

    Jarod Long's Avatar

    Ahh, that's exactly it! You're awesome!

    The problem occurs if you copy a set of divisions and try to paste them with multiple measures highlighted. It will work fine if you explicitly copy the entire measure with Command + Shift + C, so until this issue is fixed try to either do that or just not paste over multiple measures. I'll get this fixed for the next update.

    Thanks so much. I don't think I would have figured this out without your help.

  15. 15 Posted by Dartagnan Sween... on 19 Apr, 2014 09:20 AM

    Dartagnan Sweeney's Avatar

    Hi Jarod,

    Since I was emailing you last, I've had no problems and been enjoying the software. Thanks for your help.

    I have just downloaded tabular for the iPad and I'm quite happy about that. I have been trying to turn on iCloud storage and every time I do it closes the app. From then on, it won't open for me. I'm sure it's not me causing it but I have been known to be wrong in the past.

    Also, I tried to go into the upgrade screen and I could scroll down to select anything, it kept bouncing me up to the top of the screen.

    Dartagnan

  16. Support Staff 16 Posted by Jarod Long on 19 Apr, 2014 05:35 PM

    Jarod Long's Avatar

    Hey Dartagnan, good to hear from you again!

    So the app isn't starting at all anymore? I've seen some iCloud-related crash reports that I'm looking into that I'm sure are causing this. Can you double check your iCloud settings and make sure that Documents & Data are enabled, and that Tabular is enabled inside of the Documents & Data menu? I believe that deleting and reinstalling the app will let you start it up again for now, and you may unfortunately need to avoid using iCloud for now if this same issue keeps happening. This should hopefully all be fixed by the next update.

    I've just heard about the issue that's won't let you scroll in the upgrade screen, so I'm investigating that now. Are you using an iPad Mini by any chance?

  17. 17 Posted by Dartagnan Sween... on 19 Apr, 2014 07:37 PM

    Dartagnan Sweeney's Avatar

    Hey Jarod,

    I am using an iPad 4 but this has fixed both issues and picked up all the songs from my Mac.

    Thanks again for your help, I hope business is going well for you!

    Dartagnan

  18. Support Staff 18 Posted by Jarod Long on 19 Apr, 2014 07:41 PM

    Jarod Long's Avatar

    Awesome, I'm glad it's working for you now! I've fixed the issue with the upgrade screen and I'm investigating the iCloud problem now.

    Thanks so much, I really appreciate it! Let me know if there's anything else I can do for you!

Discussions are closed to public comments.
If you need help with Chromatic Labs please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac